最新消息內容

LD
[漏洞預警]Exim存在安全漏洞(CVE-2019-15846),讓攻擊者遠端執行任意程式碼,請儘速確認並進行更新


發佈日期
19-09-11
公告人員
曾國旭

[內容說明:]
轉發國家資安資訊分享與分析中心 資安訊息警訊 NISAC-ANA-201909-0051
Exim是劍橋大學開發的郵件傳送代理程式(Mail Transfer Agent,MTA),主要安裝在Linux郵件伺服器上。
研究人員發現,當Exim伺服器接受TLS連線時(預設為啟用),在最初的TLS交握過程中,存在字元(反斜線)處理不當的安全漏洞(CVE-2019-15846),導致攻擊者可利用此漏洞,透過發送惡意請求,進而遠端以root權限執行任意程式碼。

[影響平台:]
Exim 4.92.1(含)以前版本

[建議措施:]
1. 請執行「exim -bV」指令確認目前使用的版本。
2. 如使用受影響之Exim版本,請至官方網站(https://downloads.exim.org/exim4/)下載並更新至Exim 4.92.2以後版本。

[參考資料:]
1. https://www.exim.org/static/doc/security/CVE-2019-15846.txt
2. https://nvd.nist.gov/vuln/detail/CVE-2019-15846
3. https://thehackernews.com/2019/09/exim-email-server-vulnerability.html
4. https://www.ithome.com.tw/news/132935